MFGS Portal Not Accessible

Incident Report for mfgs Cloud status page

Resolved

The issue has now been resolved. We again apologize for the inconvenience and thank you for your patience.
Posted Dec 15, 2025 - 05:33 UTC

Investigating

The team has detected a backend issue with the MFGS Portal. We're working on resolve the issue and apologize for any inconvenience.
Posted Dec 15, 2025 - 05:19 UTC
This incident affected: MFGS Portal.